How to generate Javadoc?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

How to generate Javadoc?

Frizz
Hi there,

I just downloaded wss4j-2.1.1-source-release.zip and tried to generate the javadocs for the project by running "mvn javadoc:javadoc" in the project root directory - but it failed:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-javadoc-plugin:2.10.3:javadoc (default-cli) on project wss4j-bindings: An error has occurred in JavaDocs report generation:
[ERROR] Exit code: 1 - D:\Projects\Apache\wss4j-2.1.1\bindings\src\main\java\org\apache\wss4j\binding\wss10\AttributedString.java:53: error: bad use of '>'
[ERROR] * <complexType name="AttributedString">
[ERROR] ^
[ERROR] D:\Projects\Apache\wss4j-2.1.1\bindings\src\main\java\org\apache\wss4j\binding\wss10\AttributedString.java:54: error: bad use of '>'
[ERROR] *   <simpleContent>
[ERROR] ^
[ERROR] D:\Projects\Apache\wss4j-2.1.1\bindings\src\main\java\org\apache\wss4j\binding\wss10\AttributedString.java:55: error: bad use of '>'
[ERROR] *     <extension base="<http://www.w3.org/2001/XMLSchema>string">
....

How do I fix this?

cheers,
F.
Reply | Threaded
Open this post in threaded view
|

Re: How to generate Javadoc?

Colm O hEigeartaigh-2

It's working now (for WSS4J trunk).

Colm.

On Wed, Sep 23, 2015 at 7:30 AM, Frizz <[hidden email]> wrote:
Hi there,

I just downloaded wss4j-2.1.1-source-release.zip and tried to generate the javadocs for the project by running "mvn javadoc:javadoc" in the project root directory - but it failed:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-javadoc-plugin:2.10.3:javadoc (default-cli) on project wss4j-bindings: An error has occurred in JavaDocs report generation:
[ERROR] Exit code: 1 - D:\Projects\Apache\wss4j-2.1.1\bindings\src\main\java\org\apache\wss4j\binding\wss10\AttributedString.java:53: error: bad use of '>'
[ERROR] * &lt;complexType name="AttributedString">
[ERROR] ^
[ERROR] D:\Projects\Apache\wss4j-2.1.1\bindings\src\main\java\org\apache\wss4j\binding\wss10\AttributedString.java:54: error: bad use of '>'
[ERROR] *   &lt;simpleContent>
[ERROR] ^
[ERROR] D:\Projects\Apache\wss4j-2.1.1\bindings\src\main\java\org\apache\wss4j\binding\wss10\AttributedString.java:55: error: bad use of '>'
[ERROR] *     &lt;extension base="&lt;http://www.w3.org/2001/XMLSchema>string">
....

How do I fix this?

cheers,
F.



--
Colm O hEigeartaigh

Talend Community Coder
http://coders.talend.com